_WinAPI_GetProcessCommandLine​() funktioniert scheinbar nicht mehr?

  • Quatsch, das ist so, als ob du Äpfel mit Birnen vergleichst... in Post #9 verwendest du in dem Run() den Befehl Find, in Post #14 machst du es ganz anders - ohne Find.

    Könnte man so verstehen, aber ich meinte "das Problem mit dem Suchstring" - im neuen Script also ohne Problem da ohne Find und funktioniert ja perfekt;)

    Dasselbe wie bei dir: Hiermit werden alle Prozesse, die dem Suchmuster entsprechen, terminiert (gekillt).

    Kannte ich auch noch nicht, wieder was gelernt - merke ich mir für andere Einsätze, spart einiges an Code. Aber im Moment will ich den User noch fragen, ob er einverstanden ist mit dem Beenden seiner Fenster oder ob er sie lieber selbst schließt und das Programm wartet so lange.

    Falls es interessiert: wir nutzen den Webdriver und die UDF dazu von DANp und haben es noch nicht geschafft, eine erneute Verbindung mit einem noch laufenden Webdriver aufzunehmen, wenn der User das Programm vorher beendet hat. Und da wir immer genau dasselbe Profil benötigen, hängt die Geschichte beim Neustart, da ein neuer Chrome nicht auf das noch in Nutzung befindliche Profil zugreifen kann und stattdessen ein neues produziert. Bleibt nur Terminieren von altem Webdriver und allen Chromes oder Edges, die ihr Profil blockieren. Falls jemand eine brauchbare Beschreibung findet, wie man die Verbindung zu einem laufenden Webdriver wieder neu aufnehmen kann, großen Dank!


    Zitat von HansJ54 Und wmic path und wmic process sind gleich? Hä?

    Wie schon erwähnt, ich kannte den Befehl wmic bis vorgestern überhaupt noch nicht, erst durch Deine Info. Und ich habe außer auf der Seite von Apfelböck nirgendwo eine brauchbare Beschreibung gefunden. Daher der Gedanke "Process" beschäftigt sich mit den Prozessen (das war mein Ziel) und "Path" war für mich gedanklich ganz etwas anderes. Funktioniert aber scheinbar für meinen Zweck genau so gut.


    Auf jeden Fall danke für Eure Hilfe!

  • He He - das ist nicht auf meinem Mist gewachsen. :rofl:

    Eure Namen sind zum Verwechseln ähnlich - zumindest wenn es so warm ist wie jetzt :rofl:


    Gleich noch eine doofe Frage: der String, den ich mit StringSplit in das Array stecke, hat am Ende einmal einen leeren Eintrag und dann noch einen mit 1 Byte. Jetzt brauche ich mal eine Idee, wie ich den String vor dem Zerlegen in Hex Byte für Byte anzeigen kann um zu sehen, was da hinten dran hängt. Auf Anhieb nichts dazu gefunden, wie das geht.

    • Offizieller Beitrag

    Gleich noch eine doofe Frage: der String, den ich mit StringSplit in das Array stecke, hat am Ende einmal einen leeren Eintrag und dann noch einen mit 1 Byte. Jetzt brauche ich mal eine Idee, wie ich den String vor dem Zerlegen in Hex Byte für Byte anzeigen kann um zu sehen, was da hinten dran hängt. Auf Anhieb nichts dazu gefunden, wie das geht.

    - Du splittest die Consolenausgabe (am Zeilenumbruch?)

    - Du hast Leerzeilen drin

    - Ein String hat nur ein Byte

    Habe ich das richtig verstanden?


    Splitten der Konsolenausgabe muss man differenzierter machen. Es wird ständig was (auch Leeres) in die Konsole ausgegeben solange die PID existiert, da musst du schon beim Abgreifen der Ergebnisse korrigieren.

    Kannst ja mal auf diese Fuktionen zurückgreifen: