ADODB.Connection richtig geschlossen?

  • Hallo Gemeinde,

    ich öffne und schließe den MS-Access-Zugriff mit nachfolgendem Code:

    Der Zugriff funktioniert soweit bestens. Meine Frage: Schließe ich die den Zugriff richtig so oder fehlt etwas?

    Ich kann nämlich im Explorer beobachten, daß beim Zugriff via Proggi auf die Db, im Explorer eine *.laccdb-Datei angelegt wird, diese aber nicht mehr gelöscht wird.
    Ich habe die Db für exclusiven Zugriff eingerichtet und wenn ich sie per Doppelklick manuell starte wird die laccdb-datei nicht angelegt.

    Wenn ich es richtig verstanden habe bedeutet die laccdb-Datei, dass die Db als gesperrt markiert ist.
    Da alles soweit funktioniert fiel mir das erst gar nicht auf und in der laccdb steht ja auch nichts drin.


    Erst als bei manuellem Öffnen, die Erstellung einer Sicherheitskopie(VBA-Modul in der Db) mit Laufzeitfehler 70 fehlschlug

    ist mir klar geworden, dass die DB wohl i-wie gesperrt bleibt...


  • Bist Du sicher, dass die Statements ausgeführt werden? Und nicht eventuell im Code davor irgendwo ein Exit das Programm beendet?

  • Hallo water,

    ich hoffe du hattest ein schönes Weihnachtsfest und einen guten Rutsch. Jedenfalls wünsche ich euch allen ein vor allem gesundes neues Jahr :part: :thumbup:


    Also der hier angesprochene Fehler kommt von einem Microsoft-Office-Update. Dieses verhindert den im VBA-Modul gezeigten "Kopiervorgang."
    Der dazugehörige Fix hat zwar bei der Produktiv-Db geholfen, nicht jedoch bei der von mir genutzten Kopie der Db. Anfrage bei MS läuft noch...

  • Hallo Hipfzwirgel,


    ich wünsche Dir auch ein gutes Neus Jahr :part: :rock:
    Mögen solche Fehler in Zukunft nicht mehr auftreten :Glaskugel:

  • Hier mehr Informationen zum Microsoft Bug und dem aktuellen Fix Status:

    Error in Access when opening a database on a network file share


    Das Problem wurde je nach Office Version bislang nur teilweise behoben. Problematisch sind nachwievor DB Zugriffe, die über gemappte Laufwerke erfolgen. Direkter lokaler Zugriff oder über UNC Pfade sollte mittlerweile wieder funktionieren, sofern die dort genannten Patches installiert wurden.


    Wir haben seit Dezember das selbe Problem mit unserer Personalwirtschaft.

  • Hallo misterspeed,

    danke für den Tipp im Namen aller Interessierten. Das war nach Rücksprache mit unserem MS-Ansprechpartner und verantwortlichem Admin
    auch mein Sachstand. Jetzt hoffe ich, dass MS das auch für lokale Zugriffe(bei mir die Kopierfunction per Scripting.FileSystemObject ) gefixt bekommt... ;)